firebase_admin 0.2.0-dev.5
firebase_admin: ^0.2.0-dev.5 copied to clipboard

A port of the Firebase admin sdk to pure, idiomatic Dart code

39
likes
110/ 130
pub points
83%
popularity

We analyzed this package on Oct 5, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 110 out of 178 API elements (61.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:firebase_admin/firebase_admin.dart that imports:
  • package:firebase_admin/src/credential.dart that imports:
  • package:firebase_admin/src/auth/credential.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/app/app_extension.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/storage.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
clock^1.1.01.1.01.1.0
collection^1.15.01.15.01.15.0
crypto_keys^0.3.00.3.00.3.0
dotenv^3.0.03.0.03.0.0
firebase_dart^1.0.0-dev.451.0.0-dev.491.0.0-dev.49
gcloud^0.8.00.8.30.8.3
http^0.13.00.13.40.13.4
jose^0.3.20.3.20.3.2
meta^1.4.01.7.01.7.0
openid_client^0.4.10.4.30.4.3
path^1.8.01.8.01.8.0
x509^0.2.20.2.20.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.21.0.2
args-2.3.02.3.0
asn1lib-1.0.21.0.2
async-2.8.22.8.2
charcode-1.3.11.3.1
convert-3.0.13.0.1
crypto-3.0.13.0.1
expressions-0.2.30.2.3
googleapis-3.0.05.0.1
googleapis_auth-1.1.01.1.0
hive-2.0.42.0.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
petitparser-4.3.04.3.0
pointycastle-3.3.43.3.4
quiver-3.0.13.0.1
rxdart-0.27.20.27.2
sortedmap-0.5.10.5.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4
web_socket_channel-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.2, Dart 2.14.2.

39
likes
110
pub points
83%
popularity

Publisher

appsup.be

A port of the Firebase admin sdk to pure, idiomatic Dart code

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

clock, collection, crypto_keys, dotenv, firebase_dart, gcloud, http, jose, meta, openid_client, path, x509

More

Packages that depend on firebase_admin