film_gyaan 1.0.5 copy "film_gyaan: ^1.0.5" to clipboard
film_gyaan: ^1.0.5 copied to clipboard

An unofficial dart SDK which will connect to TheMovieDB. This package can be used to get Movie/TV/Person related details.

4
likes
110/ 140
pub points
0%
popularity

We analyzed this package 39 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/pradyotprksh/film_gyaan/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: film_gyaan,
    • contains a version property, and,
    • does not contain a publish_to property.

Could not find any pubspec.yaml in the repository.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

289 out of 847 API elements (34.1 %) have documentation comments.

Some symbols that are missing documentation: film_gyaan, film_gyaan.core.AlternativeTitlesParams.movieId, film_gyaan.core.AuthorDetails, film_gyaan.core.AuthorDetails.AuthorDetails, film_gyaan.core.AuthorDetails.avatarPath.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:film_gyaan/film_gyaan.dart that imports:
  • package:film_gyaan/src/networking/response/response.dart that imports:
  • package:film_gyaan/core.dart that imports:
  • package:film_gyaan/src/core/logging/logging.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/dx/movies/movies.dart:1:1

  ╷
1 │ ////////////////////////////////////////////////////////////////////////////////
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dx/movies/movies.dart

INFO: Dangling library doc comment.

lib/src/dx/people/people.dart:1:1

  ╷
1 │ ////////////////////////////////////////////////////////////////////////////////
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dx/people/people.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.4 0.13.6 1.2.1
logger ^1.1.0 1.4.0 2.2.0
pedantic ^1.11.1 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^1.1.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

4
likes
110
pub points
0%
popularity

Publisher

unverified uploader

An unofficial dart SDK which will connect to TheMovieDB. This package can be used to get Movie/TV/Person related details.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, logger, pedantic

More

Packages that depend on film_gyaan