filepicker_windows 0.1.0
filepicker_windows: ^0.1.0 copied to clipboard

A plugin that uses FFI to offer file selection in Windows using the modern common item dialog box.

46
likes
80 / 130
pub points
90 %
popularity

We analyzed this package on Jun 12, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 24 API elements (87.5 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:filepicker_windows/filepicker_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.1.2
flutterflutter0.0.00.0.0
win32^1.4.21.7.4+12.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^1.4.2` on win32 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions win32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

46
likes
80
pub points
90%
popularity

Publisher

sneath.org

A plugin that uses FFI to offer file selection in Windows using the modern common item dialog box.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LICENSE

Dependencies

ffi, flutter, win32

More

Packages that depend on filepicker_windows