filepicker_windows 1.0.0
filepicker_windows: ^1.0.0 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

A plugin that uses FFI to offer file selection in Windows using the modern common item dialog box.

22
likes
90 / 110
pub points
82 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 79 out of 97 API elements (81.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:filepicker_windows/filepicker_windows.dart that imports:
  • package:filepicker_windows/src/savedialog.dart that imports:
  • package:filepicker_windows/src/filedialog.dart that imports:
  • package:win32/win32.dart that imports:
  • package:win32/src/generated/IWbemServices.dart that imports:
  • package:win32/src/generated/IUnknown.dart that imports:
  • package:win32/src/structs.dart that imports:
  • package:win32/src/oleaut32.dart that imports:
  • package:win32/src/com/combase.dart that imports:
  • package:win32/src/utils.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/allocation.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.0.0
win32^1.7.31.7.4+12.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`, that was published 17 days ago.

When ffi is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^1.7.3` on win32 does not support the stable version `2.0.0`, that was published 17 days ago.

When win32 is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions win32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

22
likes
90
pub points
82%
popularity

Publisher

sneath.org

A plugin that uses FFI to offer file selection in Windows using the modern common item dialog box.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

ffi, win32

More

Packages that depend on filepicker_windows