filepicker_windows 0.0.1
filepicker_windows: ^0.0.1 copied to clipboard

A plugin for selecting files in Windows

47
likes
70 / 130
pub points
90 %
popularity

We analyzed this package on Jun 12, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 6 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:filepicker_windows/filepicker_windows.dart that imports:
  • package:win32/win32.dart that imports:
  • package:win32/src/generated/IWbemServices.dart that imports:
  • package:win32/src/generated/IUnknown.dart that imports:
  • package:win32/src/structs.dart that imports:
  • package:win32/src/oleaut32.dart that imports:
  • package:win32/src/com/combase.dart that imports:
  • package:win32/src/utils.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/allocation.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.1.2
flutterflutter0.0.00.0.0
win32^1.4.0-dev.11.7.4+12.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^1.4.0-dev.1` on win32 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions win32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

47
likes
70
pub points
90%
popularity

Publisher

sneath.org

A plugin for selecting files in Windows

Repository (GitHub)
View/report issues

Documentation

API reference

License

LICENSE

Dependencies

ffi, flutter, win32

More

Packages that depend on filepicker_windows