file_selector_platform_interface 1.0.0
file_selector_platform_interface: ^1.0.0

Flutter Android iOS web

A common platform interface for the file_selector plugin.

0
likes
80 / 110
pub points
40 %
popularity

We analyzed this package on Nov 21, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 33 API elements (97.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Avoid using braces in interpolation when not needed.

lib/src/web_helpers/web_helpers.dart:26:32

   ╷
26 │   var target = querySelector('#${id}');
   │                                ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/web_helpers/web_helpers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+10.12.20.12.2
meta^1.0.51.3.0-nullsafety.61.3.0-nullsafety.6
plugin_platform_interface^1.0.11.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
http_parser-3.1.43.1.4
path-1.7.01.8.0-nullsafety.3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs