file_picker 8.0.6 copy "file_picker: ^8.0.6" to clipboard
file_picker: ^8.0.6 copied to clipboard

A package that allows you to use a native file explorer to pick single or multiple absolute file paths, with extension filtering support.

4196
likes
160/ 160
pub points
100%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/miguelpruivo/flutter_file_picker/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 38 API elements (60.5 %) have documentation comments.

Some symbols that are missing documentation: file_picker, file_picker.FilePicker.platform, file_picker.FilePickerResult, file_picker.FilePickerResult.FilePickerResult, file_picker.FilePickerStatus.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/linux/file_picker_linux.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cross_file ^0.3.3+7 0.3.4+1 0.3.4+1
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.17 2.0.20 2.0.20
flutter_web_plugins flutter 0.0.0 0.0.0
path ^1.8.2 1.9.0 1.9.0
plugin_platform_interface ^2.1.8 2.1.8 2.1.8
web ^0.5.1 0.5.1 1.0.0
win32 ^5.5.1 5.5.1 5.5.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.1` on web does not support the stable version `1.0.0`, that was published 2 days ago.

When web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4196
likes
160
pub points
100%
popularity

Publisher

verified publishermiguelruivo.com

A package that allows you to use a native file explorer to pick single or multiple absolute file paths, with extension filtering support.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

Dependencies

cross_file, ffi, flutter, flutter_plugin_android_lifecycle, flutter_web_plugins, path, plugin_platform_interface, web, win32

More

Packages that depend on file_picker