figma_icon_builder 0.3.0 icon indicating copy to clipboard operation
figma_icon_builder: ^0.3.0 copied to clipboard

Fetch and export icons from figma

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package in the last hour, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 19 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:figma_icon_builder/figma_icon_builder.dart that imports:
  • package:figma_icon_builder/icon_fetcher.dart that imports:
  • package:figma_icon_builder/class_builder.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/macro.dart that imports:
  • package:analyzer/src/summary2/kernel_compilation_service.dart that imports:
  • package:_fe_analyzer_shared/src/macros/compiler/request_channel.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: Unnecessary braces in a string interpolation.

lib/class_builder.dart:35:41

   ╷
35 │         fieldBuilder.assignment = Code('${width}');
   │                                         ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/class_builder.dart

INFO: Unnecessary braces in a string interpolation.

lib/class_builder.dart:42:41

   ╷
42 │         fieldBuilder.assignment = Code('${height}');
   │                                         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/class_builder.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
code_builder^4.0.04.4.04.4.0
concurrent_queue^1.3.01.4.01.4.0
console^4.1.04.1.04.1.0
dart_style^2.0.12.2.42.2.4
dotenv^3.0.03.0.04.1.0
figma^3.0.03.6.03.6.0
figma_icon^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
glob^2.0.12.1.12.1.1
http^0.13.00.13.50.13.5
path^1.8.01.8.31.8.3
path_drawing^0.5.10.5.1+11.0.1
recase^4.0.04.1.04.1.0
xml^5.1.25.4.16.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-52.0.052.0.0
analyzer-5.4.05.4.0
args-2.3.22.3.2
async-2.10.02.10.0
built_collection-5.1.15.1.1
built_value-8.4.38.4.3
characters-1.2.11.2.1
collection-1.17.01.17.1
convert-3.1.13.1.1
copy_with_extension-2.0.25.0.0
crypto-3.0.23.0.2
equatable-2.0.52.0.5
file-6.1.46.1.4
fixnum-1.1.01.1.0
http2-2.0.12.0.1
http_parser-4.0.24.0.2
js-0.6.50.6.7
json_annotation-4.8.04.8.0
matcher-0.12.140.12.14
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
package_config-2.1.02.1.0
path_parsing-0.2.11.0.1
petitparser-5.1.05.1.0
pub_semver-2.1.32.1.3
rxdart-0.27.70.27.7
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.0` on dotenv does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dotenv to update the constraint.

The constraint `^0.5.1` on path_drawing does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions path_drawing to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.