ferry 0.10.2+1
ferry: ^0.10.2+1 copied to clipboard

Ferry is a simple, powerful GraphQL Client for Flutter and Dart.

104
likes
130 / 130
pub points
91 %
popularity

We analyzed this package on May 18, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 69 API elements (37.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_value^8.0.48.0.68.0.6
collection^1.15.01.15.01.15.0
ferry_cache^0.5.2+10.5.2+10.5.2+1
ferry_exec^0.1.20.1.20.1.2
gql^0.13.0-nullsafety.20.13.00.13.0
gql_exec^0.3.0-nullsafety.20.3.00.3.0
gql_link^0.4.0-nullsafety.30.4.00.4.0
hive^2.0.02.0.42.0.4
meta^1.3.01.3.01.3.0
normalize^0.5.10.5.10.5.1
rxdart^0.26.00.26.00.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
built_collection-5.0.05.0.0
crypto-3.0.13.0.1
ferry_store-0.4.20.4.2
fixnum-1.0.01.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`, that was published 11 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.2, Dart 2.13.0.

104
likes
130
pub points
91%
popularity

Publisher

gql-dart.dev

Ferry is a simple, powerful GraphQL Client for Flutter and Dart.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

built_value, collection, ferry_cache, ferry_exec, gql, gql_exec, gql_link, hive, meta, normalize, rxdart

More

Packages that depend on ferry