fconsole 2.6.1 copy "fconsole: ^2.6.1" to clipboard
fconsole: ^2.6.1 copied to clipboard

An overlay console log list like v-console.

18
likes
100/ 140
pub points
79%
popularity

We analyzed this package 19 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

30 out of 118 API elements (25.4 %) have documentation comments.

Some symbols that are missing documentation: fconsole, fconsole.BottomActionView, fconsole.BottomActionView.BottomActionView, fconsole.BottomActionView.onClear, fconsole.ConsoleContainer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:fconsole/fconsole.dart that imports:
  • package:fconsole/src/delegate/custom_card_delegate.dart that imports:
  • package:fconsole/src/widget/flow_info.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus_platform_interface/share_plus_platform_interface.dart that imports:
  • package:share_plus_platform_interface/platform_interface/share_plus_platform.dart that imports:
  • package:share_plus_platform_interface/method_channel/method_channel_share.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:fconsole/fconsole.dart that imports:
  • package:fconsole/src/delegate/custom_card_delegate.dart that imports:
  • package:fconsole/src/widget/console.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:fconsole/fconsole.dart that imports:
  • package:fconsole/src/delegate/custom_card_delegate.dart that imports:
  • package:fconsole/src/widget/console.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:fconsole/fconsole.dart that imports:
  • package:fconsole/src/delegate/custom_card_delegate.dart that imports:
  • package:fconsole/src/widget/console.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:fconsole/fconsole.dart that imports:
  • package:fconsole/src/delegate/custom_card_delegate.dart that imports:
  • package:fconsole/src/widget/console.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 36 issues. Showing the first 2:

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/model/flow.dart:87:22

   ╷
87 │     Duration? timeout: const Duration(seconds: 30),
   │                      ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/flow.dart

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/src/model/flow.dart:96:9

   ╷
96 │     if (logs!.length == 0) {
   │         ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/flow.dart

failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
animations ^2.0.0 2.0.11 2.0.11
device_info_plus ^9.0.3 9.1.2 9.1.2
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
intl any 0.18.1 0.19.0
json_view ^0.4.0 0.4.2 0.4.2
left_scroll_actions ^2.0.0 2.1.2 2.1.2
share_plus ^4.0.7 4.5.3 7.2.2
tapped ^2.0.0 2.0.0 2.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
share_plus_linux - 3.0.1 3.0.1
share_plus_macos - 3.0.1 3.0.1
share_plus_platform_interface - 3.3.1 3.3.1
share_plus_web - 3.1.0 3.1.0
share_plus_windows - 3.0.1 4.0.0
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
url_launcher - 6.2.5 6.2.5
url_launcher_android - 6.3.0 6.3.0
url_launcher_ios - 6.2.4 6.2.4
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.0 2.3.0
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
win32_registry - 1.1.2 1.1.2
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.7` on share_plus does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions share_plus to update the constraint.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.