fcode_common 0.0.15
fcode_common: ^0.0.15 copied to clipboard

Flutter Android iOS

Common algorithms and Widgets that are used by fcode labs (pvt) ltd for thier flutter apps production

3
likes
90 / 110
pub points
65 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 118 out of 119 API elements (99.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fcode_common/fcode_common.dart that imports:
  • package:fcode_common/src/widget/widget.dart that imports:
  • package:fcode_common/src/widget/past_time.dart that imports:
  • package:fcode_common/src/algo/algo.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.42.1.53.0.0
device_info^1.0.01.0.02.0.0
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.0
intl^0.16.10.16.10.17.0
meta^1.1.81.3.0-nullsafety.31.3.0
rxdart^0.25.00.25.00.26.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
device_info_platform_interface-1.0.12.0.0
http_parser-3.1.44.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.4` on crypto does not support the stable version `3.0.0`, that was published 27 days ago.

When crypto is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^1.0.0` on device_info does not support the stable version `2.0.0`, that was published 4 days ago.

When device_info is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

3
likes
90
pub points
65%
popularity

Publisher

fcodelabs.com

Common algorithms and Widgets that are used by fcode labs (pvt) ltd for thier flutter apps production

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, device_info, flutter, http, intl, meta, rxdart

More

Packages that depend on fcode_common