fcm_push 1.3.1
fcm_push: ^1.3.1 copied to clipboard

A Dart interface to Firebase Cloud Messaging (FCM) for Android and iOS

5
likes
60/ 130
pub points
55%
popularity

We analyzed this package 21 hours ago, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:80:47

   ╷
80 │ <p>If this plugin is helpful for you - please <a href="http://gplus.mikemitterer.at/">(Circle)</a> me,<br />
   │                                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 3 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-fcm-push/compare/v1.3...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 59 API elements (15.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

bin/fcm-push.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/cmdline.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.01.1.12.0.1
args^1.5.01.6.02.3.0
console_log_handler>=1.1.0 <2.0.01.1.61.1.6
firebase^5.0.05.0.49.0.2
http>=0.11.3 <1.0.00.12.20.13.4
http_utils>=1.6.0 <2.0.01.6.31.6.3
logging>=0.11.3 <1.0.00.11.41.0.2
path>=1.6.0 <2.0.01.8.01.8.0
tuple^1.0.01.0.32.0.0
validate^1.7.01.7.01.7.0
yaml^2.1.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
pedantic-1.11.11.11.1
quiver-2.1.53.0.1+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^1.0.0` on ansicolor does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^1.5.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.0.

5
likes
60
pub points
55%
popularity

A Dart interface to Firebase Cloud Messaging (FCM) for Android and iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ansicolor, args, console_log_handler, firebase, http, http_utils, logging, path, tuple, validate, yaml

More

Packages that depend on fcm_push