favicon 1.0.13
favicon: ^1.0.13 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Library for finding favicons in a website, either in a <link> or by predefined URL.

4
likes
90 / 110
pub points
70 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/favicon_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 15 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.14.0+30.14.0+40.15.0
http^0.12.0+40.12.20.13.0
image^2.1.122.1.192.1.19
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.0.0
args-1.6.02.0.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
http_parser-3.1.44.0.0
meta-1.2.41.3.0
path-1.7.01.8.0
petitparser-3.1.04.0.2
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0+3` on html does not support the latest published version `0.15.0`

pubspec.yaml:11:9

   ╷
11 │   html: ^0.14.0+3
   │         ^^^^^^^^^
   ╵
The constraint `^0.12.0+4` on http does not support the latest published version `0.13.0`

pubspec.yaml:10:9

   ╷
10 │   http: ^0.12.0+4
   │         ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

4
likes
90
pub points
70%
popularity

Library for finding favicons in a website, either in a <link> or by predefined URL.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

majohansson@gmail.com

License

MIT (LICENSE)

Dependencies

html, http, image

More

Packages that depend on favicon