epub_view 1.0.0

Flutter Android iOS

Flutter widget for view EPUB documents on on Web, MacOs, Android and iOS. Based on dart-epub package.

16
likes
80 / 110
pub points
74 %
popularity

We analyzed this package on Sep 28, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 96 API elements (7.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:epub_view/epub_view.dart that imports:
  • package:epub_view/src/ui/table_of_contents.dart that imports:
  • package:epub_view/src/epub_view.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:epub_view/epub_view.dart that imports:
  • package:epub_view/src/ui/table_of_contents.dart that imports:
  • package:epub_view/src/epub_view.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:epub_view/epub_view.dart that imports:
  • package:epub_view/src/ui/table_of_contents.dart that imports:
  • package:epub_view/src/epub_view.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:epub_view/epub_view.dart that imports:
  • package:epub_view/src/ui/table_of_contents.dart that imports:
  • package:epub_view/src/epub_view.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/html_parser.dart that imports:
  • package:flutter_html/src/layout_element.dart that imports:
  • package:flutter_html/src/html_elements.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Close instances of `dart.core.Sink`.

lib/src/epub_controller.dart:20:47

   ╷
20 │     final BehaviorSubject<EpubChapterViewValue> _valueStreamController =
   │ ┌───────────────────────────────────────────────^
21 │ │       BehaviorSubject<EpubChapterViewValue>();
   │ └─────────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/epub_controller.dart

INFO: Close instances of `dart.core.Sink`.

lib/src/epub_controller.dart:24:7

   ╷
24 │ ┌       _tableOfContentsStreamController =
25 │ │       BehaviorSubject<List<EpubViewChapter>>();
   │ └──────────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/epub_controller.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
epub^2.1.02.1.02.1.0
equatable^1.1.11.2.51.2.5
flutterflutter0.0.00.0.0
flutter_html^1.0.01.0.01.0.2
html^0.14.0+30.14.0+30.14.0+3
meta^1.1.81.1.81.2.3
rxdart^0.24.10.24.10.24.1
scrollable_positioned_list^0.1.60.1.70.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
async-2.4.22.4.2
characters-1.0.01.0.0
charcode-1.1.31.1.3
chewie-0.9.100.9.10
chewie_audio-1.0.0+11.0.0+1
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
css_colors-1.0.21.0.2
csslib-0.16.20.16.2
dart2_constant-1.0.2+dart21.0.2+dart2
flutter_svg-0.17.40.19.0
flutter_web_plugins-0.0.00.0.0
image-2.1.132.1.18
matcher-0.12.90.12.9
open_iconic_flutter-0.3.00.3.0
path-1.7.01.7.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
petitparser-3.0.43.1.0
quiver-2.1.32.1.3
screen-0.0.50.0.5
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
video_player-0.10.12+50.11.0
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.1.4+2
webview_flutter-0.3.240.3.24
xml-3.7.04.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

16
likes
80
pub points
74%
popularity

Publisher

serge.software

Flutter widget for view EPUB documents on on Web, MacOs, Android and iOS. Based on dart-epub package.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

epub, equatable, flutter, flutter_html, html, meta, rxdart, scrollable_positioned_list

More

Packages that depend on epub_view