enough_platform_widgets 1.1.0 copy "enough_platform_widgets: ^1.1.0" to clipboard
enough_platform_widgets: ^1.1.0 copied to clipboard

Useful platform aware widgets to develop a Flutter app with either Cupertino and Material design.

27
likes
120/ 140
pub points
89%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

406 out of 2585 API elements (15.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: cupertino, cupertino.CupertinoProgressBar.semanticsLabel, cupertino.CupertinoProgressBar.semanticsValue, enough_platform_widgets, enough_platform_widgets.CommonPlatformIcons.account.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Statements in an if should be enclosed in a block.

lib/src/cupertino/cupertino_multiple_segmented.dart:346:7

    ╷
346 │       return _textColorTween.evaluate(_selectionControllers[index]);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/cupertino/cupertino_multiple_segmented.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/cupertino/cupertino_multiple_segmented.dart:353:7

    ╷
353 │       return _childTweens[index].evaluate(_selectionControllers[index]);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/cupertino/cupertino_multiple_segmented.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cupertino_progress_bar ^0.2.0 0.2.0 0.2.0
cupertino_stepper ^0.2.1 0.2.1 0.2.1
flutter flutter 0.0.0 0.0.0
flutter_platform_widgets ^6.1.0 6.1.0 6.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
cupertino_icons - 1.0.8 1.0.8
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

27
likes
120
pub points
89%
popularity

Publisher

verified publisherenough.de

Useful platform aware widgets to develop a Flutter app with either Cupertino and Material design.

Repository (GitHub)
View/report issues

Topics

#cupertino #material #widgets

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cupertino_progress_bar, cupertino_stepper, flutter, flutter_platform_widgets

More

Packages that depend on enough_platform_widgets