email_validator 2.0.1 icon indicating copy to clipboard operation
email_validator: ^2.0.1 copied to clipboard

A simple (but correct) dart class for validating email addresses

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add email_validator

With Flutter:

 $ flutter pub add email_validator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  email_validator: ^2.0.1

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:email_validator/email_validator.dart';
562
likes
110
pub points
99%
popularity

Publisher

unverified uploader

A simple (but correct) dart class for validating email addresses

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on email_validator