email_validator 1.0.6
email_validator: ^1.0.6

Dart native js
Flutter Android iOS web

A simple (but correct) dart class for validating email addresses

example/example.dart

import 'dart:core';
import 'package:email_validator/email_validator.dart';

void main() {
    const String email = 'fredrik.eilertsen@gail.com';
    final bool isValid = EmailValidator.validate(email);

    print('Email is valid? ' + (isValid ? 'yes' : 'no'));
}
192
likes
110
pub points
98%
popularity

A simple (but correct) dart class for validating email addresses

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fredrik.eilertsen@gmail.com

License

MIT (LICENSE)

More

Packages that depend on email_validator