email_validator 2.1.17 icon indicating copy to clipboard operation
email_validator: ^2.1.17 copied to clipboard

A simple (but correct) dart class for validating email addresses

2.1.17 #

Duplicate type enum found in flutter

2.1.7 #

Duplicate type enum found in flutter

2.1.16 #

Bug fixes and performance improvements

2.1.15 #

Bug fixes and performance improvements

2.1.2 #

Fix static anlyzer warnings and update Dart SDK

2.0.1 #

Migrate to new null safety SDK. See https://dart.dev/null-safety.

2.0.0-nullsafety #

Migrate to new null safety SDK. See https://dart.dev/null-safety.

1.0.6 #

Code clean up

1.0.5 #

Add parameter documentation for the EmailValidator.validate method

1.0.4 #

Fix Dart sdk analysis warnings

1.0.3 #

Minor code style fixes again

1.0.2 #

Minor code style fixes

1.0.1 #

Allow international now defaults to true.

1.0.0 #

EmailValidator.Validate() is now, by Dart convention, EmailValidator.validate().

0.1.6 #

Cleaned up code a bit, no API changes.

0.1.5 #

Cleaned up code a bit, no API changes.

0.1.4 #

Now supports a broader variety of Dart sdk versions

0.1.0 #

Validate emails through a static method EmailValidator.validate().

624
likes
130
pub points
99%
popularity

Publisher

unverified uploader

A simple (but correct) dart class for validating email addresses

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

More

Packages that depend on email_validator