ed25519_edwards 0.3.1 copy "ed25519_edwards: ^0.3.1" to clipboard
ed25519_edwards: ^0.3.1 copied to clipboard

Dart port of ed25519 from Go Cryptography ed25519

11
likes
140/ 160
pub points
89%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 19 API elements (78.9 %) have documentation comments.

Some symbols that are missing documentation: edwards25519.KeyPair.privateKey, edwards25519.KeyPair.publicKey, edwards25519.PrivateKey.bytes, edwards25519.PublicKey.bytes.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 39 issues. Showing the first 2:

INFO: The variable name 'SqrtM1' isn't a lowerCamelCase identifier.

lib/src/const.dart:31:5

   ╷
31 │ var SqrtM1 = FieldElement.fromList([
   │     ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/const.dart

INFO: The variable name 'FeZero' isn't a lowerCamelCase identifier.

lib/src/edwards25519.dart:41:6

   ╷
41 │ void FeZero(FieldElement fe) {
   │      ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/edwards25519.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
adaptive_number ^1.0.0 1.0.0 1.0.0
collection ^1.15.0 1.19.0 1.19.0
convert ^3.0.0 3.1.1 3.1.1
crypto ^3.0.0 3.0.3 3.0.3
Transitive dependencies
Package Constraint Compatible Latest
fixnum - 1.1.0 1.1.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

11
likes
140
pub points
89%
popularity

Publisher

unverified uploader

Dart port of ed25519 from Go Cryptography ed25519

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

adaptive_number, collection, convert, crypto

More

Packages that depend on ed25519_edwards