easy_pass_common 0.1.6
easy_pass_common: ^0.1.6 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Commons library for easy pass.

1
likes
60 / 110
pub points
6 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://desmondthuhu@dev.azure.com/desmondthuhu/Easy%20Pass/_git/easy_pass_common was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 235 API elements (5.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: 'parse' is deprecated and shouldn't be used. Renamed function to EnumToString.convertToString to make it clearer.

lib/dto/update_ticket_request.dart:11:42

   ╷
11 │     parameters = {'status': EnumToString.parse(this.status)};
   │                                          ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dto/update_ticket_request.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/service/service_base/service_base.dart:77:30

   ╷
77 │       final jsonObjectList = List<Map<String, Object>> ();
   │                              ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/service/service_base/service_base.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
email_validator^1.0.01.0.61.0.6
enum_to_string^1.0.01.0.141.0.14
flutterflutter0.0.00.0.0
flutter_secure_storage^3.0.03.3.54.0.0
get_it^4.0.04.0.46.0.0
http^0.12.0+20.12.20.13.0
intl^0.16.10.16.10.17.0
mockito^4.0.04.1.45.0.0
provider^4.0.04.3.35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-2.0.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
build-1.6.21.6.3
built_collection-5.0.05.0.0
built_value-8.0.08.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
code_builder-3.6.03.6.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.03.0.0
dart_style-1.3.121.3.14
file-6.1.06.1.0
fixnum-1.0.01.0.0
glob-2.0.02.0.0
http_parser-3.1.44.0.0
logging-1.0.01.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
nested-1.0.01.0.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+30.9.10+3
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.2.190.2.19
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^3.0.0` on flutter_secure_storage does not support the stable version `4.0.0`, that was published 10 days ago.

When flutter_secure_storage is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

The constraint `^4.0.0` on get_it does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions get_it to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.