easy_pass_common 0.1.6

  • Readme
  • Changelog
  • Installing
  • 44

easy_pass_common #

This package contains all common code between the customer and the gate keeper app

[0.0.1] - 2020-03-10 16:10. #

  • Initial release.

[0.0.2] - 2020-03-10 22:50. #

  • Feat: Added all base functionality

[0.0.3] - 2020-03-10 23:22. #

  • Feat: Added session model

[0.0.4] - 2020-03-12 20:43. #

  • Feat: Added index service call

[0.0.5] - 2020-03-12 22:42. #

  • Fix: failing tests
  • Fix: Refactor base service test
  • Fix: index breaks due to incorrect return type
  • Feat: added base service test

[0.0.6] - 2020-03-12 22:46. #

  • Fix: format documantation

[0.0.7] - 2020-03-14 12:13. #

  • Feat: added create base request
  • Fix: expose user id

[0.0.8] - 2020-03-14 12:13. #

  • Fix: exception thrown even after receiving 201

[0.0.9] - 2020-03-21 15:01. #

  • Feat: added logout functionality to session

[0.1.0] - 2020-03-21 21:28. #

  • Feat: throw different exceptions based on http code

[0.1.1] - 2020-03-24 22:07. #

  • Feat: added create user

[0.1.2] - 2020-03-24 22:20. #

  • Fix: Added password to user

[0.1.3] - 2020-03-28 18:10. #

  • Feat: added Unprocessable Entity exception
  • Fix: error when serializing create user request
  • Fix: Added password to user

[0.1.4] - 2020-03-28 20:08. #

  • Fix: format code

[0.1.5] - 2020-03-29 18:04. #

  • Feat: added event

[0.1.6] - 2020-03-29 18:04. #

  • Feat: added login and sign up page

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_pass_common: ^0.1.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_pass_common/easy_pass_common.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • easy_pass_common that is a package requiring null.

Health suggestions

Format lib/service/service_base/service_base.dart.

Run flutter format to format lib/service/service_base/service_base.dart.

Format lib/service/service_base/status.dart.

Run flutter format to format lib/service/service_base/status.dart.

Format lib/ui/view/login_view.dart.

Run flutter format to format lib/ui/view/login_view.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/ui/view/sign_up_view.dart (Run flutter format to format lib/ui/view/sign_up_view.dart.)
  • lib/ui/widget/network_error_dialog.dart (Run flutter format to format lib/ui/widget/network_error_dialog.dart.)
  • lib/ui/widget/sign_up_date_picket.dart (Run flutter format to format lib/ui/widget/sign_up_date_picket.dart.)
  • lib/ui/widget/sing_in/sign_in_email_input.dart (Run flutter format to format lib/ui/widget/sing_in/sign_in_email_input.dart.)
  • lib/ui/widget/sing_in/sign_in_password_input.dart (Run flutter format to format lib/ui/widget/sing_in/sign_in_password_input.dart.)
  • lib/ui/widget/sing_in/sign_in_register_user_url.dart (Run flutter format to format lib/ui/widget/sing_in/sign_in_register_user_url.dart.)
  • lib/ui/widget/sing_in/sing_in_button.dart (Run flutter format to format lib/ui/widget/sing_in/sing_in_button.dart.)
  • lib/ui/widget/sing_in_error_dialog.dart (Run flutter format to format lib/ui/widget/sing_in_error_dialog.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://desmondthuhu@dev.azure.com/desmondthuhu/Easy%20Pass/_git/easy_pass_common was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and easy_pass_common.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
email_validator ^1.0.0 1.0.4
enum_to_string ^1.0.0 1.0.9
flutter 0.0.0
flutter_secure_storage ^3.0.0 3.3.3
get_it ^4.0.0 4.0.2
http ^0.12.0+2 0.12.1
intl ^0.16.1 0.16.1
mockito ^4.0.0 4.1.1
provider ^4.0.0 4.3.1
Transitive dependencies
async 2.4.2
boolean_selector 2.0.0
charcode 1.1.3
collection 1.14.12 1.14.13
http_parser 3.1.4
matcher 0.12.8
meta 1.1.8 1.2.2
nested 0.0.4
path 1.7.0
pedantic 1.9.0 1.9.2
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.17
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test