dynamic_form 0.8.0
dynamic_form: ^0.8.0 copied to clipboard

Flutter Android iOS Linux macOS Windows

generate your form with easier way, Pre-existing forms, fields ,customize your form in runtime

2
likes
80 / 110
pub points
45 %
popularity

We analyzed this package on Feb 28, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 28 out of 314 API elements (8.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:dynamic_form/dynamic_form.dart that imports:
  • package:dynamic_form/src/controller/form_controller.dart that imports:
  • package:dynamic_form/src/simple_dynamic_form.dart that imports:
  • package:dynamic_form/src/widgets/card_number_field.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Avoid return types on setters.

lib/src/utilities/text_controller_format_input.dart:65:3

   ╷
65 │   void set text(String newText) {
   │   ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utilities/text_controller_format_input.dart

lib/dynamic_form.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flag^3.2.23.2.23.2.2
flutterflutter0.0.00.0.0
flutter_svg^0.19.10.19.10.19.3
http^0.12.20.12.20.13.0
intl^0.16.10.16.10.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
http_parser-3.1.44.0.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
pedantic-1.9.21.10.0
petitparser-3.1.04.0.2
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`, that was published 22 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`, that was published 24 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

2
likes
80
pub points
45%
popularity

generate your form with easier way, Pre-existing forms, fields ,customize your form in runtime

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

hamza.mohamedali93@gmail.com

License

MIT (LICENSE)

Dependencies

flag, flutter, flutter_svg, http, intl

More

Packages that depend on dynamic_form