dsg 1.1.0
dsg: ^1.1.0 copied to clipboard

Static site generator. Supports markdown, mustache, partials, assets, sass. Webserver included.

3
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 85 API elements (17.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dsg/dsg.dart that imports:
  • package:where/where.dart that imports:
  • package:where/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.01.6.02.3.0
console_log_handler^1.0.01.1.61.1.6
front_matter^1.1.01.1.01.1.0
http_server^0.9.00.9.8+31.0.0
intl^0.16.10.16.10.17.0
logging>=0.11.3 <1.0.00.11.41.0.2
markdown^2.1.52.1.84.0.1
packages^0.4.00.4.40.4.4
path^1.0.01.8.01.8.0
reflected_mustache^1.0.01.0.111.0.11
system_info^0.1.00.1.31.0.1
validate^1.0.01.7.01.7.0
watcher^0.9.70.9.7+151.0.1
where^8.0.08.0.08.0.0
yaml^2.1.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.030.0.0
analyzer-0.41.12.7.0
ansicolor-1.1.12.0.1
async-2.8.22.8.2
build-1.6.22.1.1
build_cli_annotations-1.2.02.0.0
build_config-0.4.51.0.0
build_daemon-2.1.103.0.1
build_resolvers-1.5.32.0.5
build_runner_core-6.1.77.2.2
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.5
code_builder-3.7.04.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
dart_style-1.3.122.2.0
file-5.2.16.1.2
file_utils-0.1.41.0.1
fixnum-1.0.01.0.0
glob-1.2.02.0.2
globbing-0.3.11.0.0
graphs-0.2.02.1.0
http_multi_server-2.2.03.0.1
http_parser-4.0.04.0.0
io-0.3.51.0.3
js-0.6.30.6.3
json_annotation-4.3.04.3.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-0.9.71.0.1
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
optional-3.1.06.1.0+1
package_config-1.9.32.0.2
pool-1.5.01.5.0
pub_semver-1.4.42.1.0
pubspec_parse-0.1.81.1.0
reflectable-2.2.93.0.4
shelf-1.2.01.2.0
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
web_socket_channel-1.2.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.4.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.9.0` on http_server does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http_server to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

3
likes
80
pub points
0%
popularity

Static site generator. Supports markdown, mustache, partials, assets, sass. Webserver included.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

args, console_log_handler, front_matter, http_server, intl, logging, markdown, packages, path, reflected_mustache, system_info, validate, watcher, where, yaml

More

Packages that depend on dsg