drift_dev 2.5.2 icon indicating copy to clipboard operation
drift_dev: ^2.5.2 copied to clipboard

Dev-dependency for users of drift. Contains the generator and development tools.

17
likes
120/ 140
pub points
97%
popularity

We analyzed this package 9 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 25 API elements (40.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:drift_dev/integrations/build.dart that imports:
  • package:drift_dev/src/backends/build/preprocess_builder.dart that imports:
  • package:drift_dev/src/backends/build/backend.dart that imports:
  • package:drift_dev/src/analysis/driver/driver.dart that imports:
  • package:drift_dev/src/analysis/driver/state.dart that imports:
  • package:drift_dev/src/analysis/driver/error.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:drift_dev/integrations/build.dart that imports:
  • package:drift_dev/src/backends/build/preprocess_builder.dart that imports:
  • package:drift_dev/src/backends/build/backend.dart that imports:
  • package:drift_dev/src/analysis/driver/driver.dart that imports:
  • package:drift_dev/src/analysis/driver/state.dart that imports:
  • package:drift_dev/src/analysis/driver/error.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:drift_dev/api/migrations.dart that imports:
  • package:sqlite3/sqlite3.dart that imports:
  • package:sqlite3/src/ffi/api/statement.dart that imports:
  • dart:ffi
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'modules' is deprecated and shouldn't be used. Use effectiveModules instead.

lib/src/generated/analysis/options.g.dart:134:20

    ╷
134 │           instance.modules.map((e) => _$SqlModuleEnumMap[e]!).toList(),
    │                    ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/generated/analysis/options.g.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^5.2.05.4.05.4.0
analyzer_plugin^0.11.00.11.20.11.2
args>=1.5.0 <3.0.02.3.22.3.2
build^2.0.02.3.12.3.1
build_config>=0.3.1 <2.0.01.1.11.1.1
build_resolvers^2.0.02.1.02.1.0
charcode^1.2.01.3.11.3.1
cli_util>=0.2.0 <0.4.00.3.50.3.5
collection^1.14.01.17.11.17.1
dart_style>=1.3.3 <3.0.02.2.42.2.4
drift>=2.5.0 <2.6.02.5.02.5.0
io^1.0.31.0.41.0.4
json_annotation^4.8.04.8.04.8.0
logging>=0.11.0 <2.0.01.1.11.1.1
meta^1.1.01.9.01.9.0
package_config^2.0.02.1.02.1.0
path^1.6.01.8.31.8.3
pub_semver^2.0.02.1.32.1.3
recase>=2.0.1 <5.0.04.1.04.1.0
source_gen>=0.9.4 <2.0.01.2.71.2.7
source_span^1.5.51.9.11.9.1
sqlite3>=0.1.6 <2.0.01.9.11.9.1
sqlparser^0.27.00.27.00.27.0
stream_transform>=0.1.0 <3.0.02.1.02.1.0
string_scanner^1.1.11.2.01.2.0
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-52.0.052.0.0
async-2.10.02.10.0
checked_yaml-2.0.22.0.2
convert-3.1.13.1.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
glob-2.1.12.1.1
graphs-2.2.02.2.0
js-0.6.70.6.7
pool-1.5.11.5.1
pubspec_parse-1.2.11.2.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.