dog 1.3.1
dog: ^1.3.1 copied to clipboard

Simple and pretty log package for Dart, includes Flutter and web.

6
likes
90 / 110
pub points
69 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 28 out of 76 API elements (36.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/formatter/pretty_formatter.dart:46:24

   ╷
46 │       List<String> l = List(lineLength);
   │                        ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/formatter/pretty_formatter.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/formatter/pretty_formatter.dart:57:24

   ╷
57 │       List<String> l = List(lineLength);
   │                        ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/formatter/pretty_formatter.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.1.01.1.12.0.1
stack_trace^1.9.51.10.01.10.0
tuple^1.0.31.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.100.12.10
meta-1.3.01.3.0
quiver-2.1.53.0.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on ansicolor does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^1.0.3` on tuple does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

6
likes
90
pub points
69%
popularity

Simple and pretty log package for Dart, includes Flutter and web.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

chenenyux@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

ansicolor, stack_trace, tuple

More

Packages that depend on dog