Dog

Pub Version

Simple and pretty log package for Dart, includes Flutter and web.

Getting Started

Install

dependencies:
  dog: any # replace 'any' with version number.
import 'package:dog/dog.dart';

Usage

// simple log
dog.v('verbose');
dog.d('debug');
dog.i('info');
dog.w('warning');
dog.e('error');

// Map.
dog.i({
  'a': 1,
  'b': {'b1': '2', 'b2': '2'},
  'c': 3
});
// Iterable.
dog.w([1, 2, 3, 4, 5]);
// Function.
dog(() => 'This this a message returned by Function.');

// Exception/StackTrace
try {
  throw Exception('This is an exception.');
} catch (e, st) {
  dog.e(e, stackTrace: st);
}

// tag and title support
dog.i({'success': true}, tag: 'HTTP', title: 'Response: https://api.example.com/');

Web platform support:

chrome

Dog level

See Level.

// disable Dog
Dog.level = Level.OFF;

Formatter

PrettyFormatter: Convert message to pretty styles.

SimpleFormatter: Format message without borders.

Emitter

ConsoleEmitter: Output message to console.

FileEmitter: Output message to file, it doesn't support web platform.

Thanks

logger: Logger for android.

Libraries

dog