documentation_builder 0.0.14 copy "documentation_builder: ^0.0.14" to clipboard
documentation_builder: ^0.0.14 copied to clipboard

Generates markdown documentation files from markdown template files.

7
likes
150/ 160
pub points
0%
popularity

We analyzed this package 10 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

96 out of 163 API elements (58.9 %) have documentation comments.

Some symbols that are missing documentation: documentation_builder, documentation_builder.ChangeLogTemplate, documentation_builder.ChangeLogTemplate.ChangeLogTemplate, documentation_builder.ChangeLogTemplateFactory, documentation_builder.ChangeLogTemplateFactory.ChangeLogTemplateFactory.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:documentation_builder/documentation_builder.dart that imports:
  • package:documentation_builder/src/builder/documentation_model_builder.dart that imports:
  • package:documentation_builder/src/builder/documentation_builder.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.13.0 5.13.0 6.6.0
build ^2.3.1 2.4.1 2.4.1
build_config ^1.1.0 1.1.1 1.1.1
build_runner ^2.2.1 2.4.11 2.4.11
collection ^1.16.0 1.19.0 1.19.0
fluent_regex ^1.0.3 1.0.3 1.0.3
http ^0.13.5 0.13.6 1.2.1
logging ^1.0.2 1.2.0 1.2.0
test ^1.21.6 1.25.7 1.25.7
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 70.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build_daemon - 4.0.2 4.0.2
build_resolvers - 2.4.2 2.4.2
build_runner_core - 7.3.1 7.3.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
checked_yaml - 2.0.3 2.0.3
code_builder - 4.10.0 4.10.0
convert - 3.1.1 3.1.1
coverage - 1.8.0 1.8.0
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 2.0.0 2.0.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
test_core - 0.6.4 0.6.4
timing - 1.0.1 1.0.1
typed_data - 1.3.2 1.3.2
vm_service - 14.2.3 14.2.3
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket - 0.1.5 0.1.5
web_socket_channel - 3.0.0 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.13.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

7
likes
150
pub points
0%
popularity

Publisher

unverified uploader

Generates markdown documentation files from markdown template files.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, build_runner, collection, fluent_regex, http, logging, test

More

Packages that depend on documentation_builder