dio 2.1.12
dio: ^2.1.12 copied to clipboard

A powerful Http client for Dart, which supports Interceptors, FormData, Request Cancellation, File Downloading, Timeout etc.

1949
likes
60 / 110
pub points
99 %
popularity

We analyzed this package on Apr 9, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/dio.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 234 out of 307 API elements (76.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dio/dio.dart that imports:
  • package:dio/src/dio_http_headers.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 66 issues. Showing the first 2:

ERROR: 'DioHttpHeaders.add' ('void Function(String, Object)') isn't a valid override of 'HttpHeaders.add' ('void Function(String, Object, {bool preserveHeaderCase})').

lib/src/dio_http_headers.dart:55:8

   ╷
55 │   void add(String name, value) {
   │        ^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dio_http_headers.dart

ERROR: 'DioHttpHeaders.set' ('void Function(String, Object)') isn't a valid override of 'HttpHeaders.set' ('void Function(String, Object, {bool preserveHeaderCase})').

lib/src/dio_http_headers.dart:70:8

   ╷
70 │   void set(String name, Object value) {
   │        ^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dio_http_headers.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cookie_jar^1.0.01.0.13.0.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on cookie_jar does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cookie_jar to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

1949
likes
60
pub points
99%
popularity

Publisher

flutterchina.club

A powerful Http client for Dart, which supports Interceptors, FormData, Request Cancellation, File Downloading, Timeout etc.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cookie_jar

More

Packages that depend on dio