dialog_flowtter 0.3.1
dialog_flowtter: ^0.3.1 copied to clipboard

A Flutter implementation of DialogFlow improved. Get your chatbots ready in no time.

13
likes
120 / 130
pub points
81 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 273 out of 343 API elements (79.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:dialog_flowtter/dialog_flowtter.dart that imports:
  • package:dialog_flowtter/src/dialog.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/metadata_server.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^2.0.02.0.32.0.3
flutterflutter0.0.00.0.0
googleapis_auth^1.1.01.1.01.1.0
http^0.13.10.13.30.13.3
json_annotation^4.0.14.0.14.0.1
meta^1.3.01.3.01.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
http_parser-4.0.04.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

13
likes
120
pub points
81%
popularity

Publisher

deimos.app

A Flutter implementation of DialogFlow improved. Get your chatbots ready in no time.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, googleapis_auth, http, json_annotation, meta

More

Packages that depend on dialog_flowtter