devtools_testing 2.3.3
devtools_testing: ^2.3.3 copied to clipboard

Package of shared testing code for Dart DevTools.

0
likes
50 / 130
pub points
20 %
popularity

We analyzed this package on Jun 19, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 287 API elements (2.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:devtools_testing/inspector_service_test.dart that imports:
  • package:devtools_testing/support/flutter_test_environment.dart that imports:
  • package:devtools_testing/support/flutter_test_driver.dart that imports:
  • package:devtools_app/src/vm_service_wrapper.dart that imports:
  • package:devtools_app/src/version.dart that imports:
  • package:devtools_app/src/utils.dart that imports:
  • package:devtools_app/src/notifications.dart that imports:
  • package:devtools_app/src/theme.dart that imports:
  • package:devtools_app/src/common_widgets.dart that imports:
  • package:devtools_app/src/scaffold.dart that imports:
  • package:devtools_app/src/app.dart that imports:
  • package:devtools_app/src/landing_screen.dart that imports:
  • package:devtools_app/src/file_import.dart that imports:
  • package:file_selector/file_selector.dart that declares support for platforms: Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/inspector_service_test.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/support/flutter_test_environment.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
devtools_app2.3.32.3.32.3.3
devtools_shared2.3.32.3.32.3.3
flutterflutter0.0.00.0.0
flutter_riverpod^0.14.0+30.14.0+30.14.0+3
flutter_testflutter0.0.00.0.0
matcher^0.12.30.12.100.12.10
meta^1.3.01.3.01.4.0
pedantic^1.11.01.11.11.11.1
vm_service^7.1.07.1.07.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansi_up-0.0.21.0.0
ansicolor-1.0.52.0.1
archive-3.1.23.1.2
args-2.1.12.1.1
async-2.6.12.7.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.3.1
clock-1.1.01.1.0
codicon-0.0.31.0.0
collection-1.15.01.15.0
convert-3.0.03.0.0
cross_file-0.3.1+10.3.1+1
crypto-3.0.13.0.1
dds-2.0.12.0.1
fake_async-1.2.01.2.0
file-6.1.26.1.2
file_selector-0.8.20.8.2
file_selector_linux-0.0.20.0.2
file_selector_macos-0.0.40.0.4
file_selector_platform_interface-2.0.22.0.2
file_selector_web-0.8.10.8.1
file_selector_windows-0.0.20.0.2
flutter_web_plugins-0.0.00.0.0
freezed_annotation-0.14.20.14.2
http-0.13.30.13.3
http_parser-4.0.04.0.0
image-3.0.23.0.2
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
json_rpc_2-3.0.13.0.1
logging-1.0.11.0.1
mime-1.0.01.0.0
nested-1.0.01.0.0
path-1.8.01.8.0
petitparser-4.1.04.2.0
platform_detect-1.4.02.0.0
plugin_platform_interface-2.0.02.0.0
pool-1.5.01.5.0
provider-5.0.05.0.0
pub_semver-1.4.42.0.0
riverpod-0.14.0+30.14.0+3
shelf-1.1.41.1.4
shelf_proxy-1.0.01.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sse-4.1.04.1.0
stack_trace-1.10.01.10.0
state_notifier-0.7.00.7.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.3.00.4.1
typed_data-1.3.01.3.0
url_launcher-5.4.06.0.6
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.12.0.3
url_launcher_web-0.1.32.0.1
usage-4.0.24.0.2
vector_math-2.1.02.1.0
vm_snapshot_analysis-0.6.00.7.0
web_socket_channel-2.1.02.1.0
xml-5.1.25.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.