devtools_testing 0.2.3

  • Readme
  • Changelog
  • Installing
  • 11

What is this? #

This is a repo containing the integration tests and testing utilities for devtools.

0.2.3 #

Coordinated release with DevTools 0.2.3

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  devtools_testing: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:devtools_testing/info_controller_test.dart';
import 'package:devtools_testing/inspector_controller_test.dart';
import 'package:devtools_testing/inspector_service_test.dart';
import 'package:devtools_testing/logging_controller_test.dart';
import 'package:devtools_testing/matchers/fake_flutter_matchers.dart';
import 'package:devtools_testing/matchers/matchers.dart';
import 'package:devtools_testing/memory_service_test.dart';
import 'package:devtools_testing/service_manager_test.dart';
import 'package:devtools_testing/support/constants.dart';
import 'package:devtools_testing/support/cpu_profile_test_data.dart';
import 'package:devtools_testing/support/fake_inspector_tree.dart';
import 'package:devtools_testing/support/file_utils.dart';
import 'package:devtools_testing/support/flutter_test_driver.dart';
import 'package:devtools_testing/support/flutter_test_environment.dart';
import 'package:devtools_testing/support/test_utils.dart';
import 'package:devtools_testing/support/timeline_test_data.dart';
import 'package:devtools_testing/timeline_controller_test.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
49
Overall:
Weighted score of the above. [more]
11
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because devtools_testing depends on devtools_app ^0.1.15 which depends on vm_service ^2.3.1, vm_service ^2.3.1 is required.
 So, because devtools_testing depends on vm_service ^3.0.0, version solving failed.

Health suggestions

Format lib/support/flutter_test_environment.dart.

Run flutter format to format lib/support/flutter_test_environment.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and devtools_testing.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0