devtools_app 0.1.10

  • Readme
  • Changelog
  • Installing
  • 12

Build Status

What is this? #

This is a companion repo to the main Flutter repo. It contains the source code for a suite of performance tools for Dart and Flutter. All of the core logic for the devtools app is in package:devtools_app with package:devtools just serving as a container to serve precompiled versions of the app for easy use with pub global activate.

Getting started #

For documentation on installing and trying out DevTools, please see our docs.

Feedback #

Feedback and issues are best reported at https://github.com/flutter/devtools/issues. Thanks for trying out DevTools!

Terms and Privacy #

By using Dart DevTools, you agree to the Google Terms of Service.

See the changelog for package:devtools which should list all changes to package:devtools_app as it is the user visible package for this work.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  devtools_app: ^0.1.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:devtools_app/devtools.dart';
import 'package:devtools_app/html_main.dart';
import 'package:devtools_app/main.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
12
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Flutter SDK version is 1.9.1+hotfix.4.
 
 Because devtools_app requires Flutter SDK version >=1.9.8-pre.31, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and devtools_app.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0