device_preview_minus 1.0.2 copy "device_preview_minus: ^1.0.2" to clipboard
device_preview_minus: ^1.0.2 copied to clipboard

A temporary alternative to device_preview. (https://pub.dev/packages/device_preview)

2
likes
120/ 140
pub points
82%
popularity

We analyzed this package 42 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

219 out of 406 API elements (53.9 %) have documentation comments.

Some symbols that are missing documentation: device_preview_minus, device_preview_minus.CustomDeviceInfoData.copyWith, device_preview_minus.CustomDeviceInfoData.CustomDeviceInfoData.fromJson, device_preview_minus.CustomDeviceInfoData.toJson, device_preview_minus.DeviceFrameStyle.copyWith.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/frame/info/identifier.dart:29:17

   ╷
29 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/frame/info/identifier.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/frame/info/info.freezed.dart:288:17

    ╷
288 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/frame/info/info.freezed.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection any 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
freezed_annotation any 2.4.1 2.4.1
json_annotation any 4.8.1 4.8.1
provider any 6.1.1 6.1.1
shared_preferences any 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.