deeplink_rpc 1.0.6 copy "deeplink_rpc: ^1.0.6" to clipboard
deeplink_rpc: ^1.0.6 copied to clipboard

A RPC-via-deeplink communication library coded in Dart. This is dedicated to Flutter mobile applications (iOS / Android).

1
likes
110/ 140
pub points
62%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: AGPL-3.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

8 out of 66 API elements (12.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: deeplink_rpc.BaseDeeplinkRpcReceiver, deeplink_rpc.BaseDeeplinkRpcReceiver.BaseDeeplinkRpcReceiver, deeplink_rpc.BaseDeeplinkRpcReceiver.canHandle, deeplink_rpc.BaseDeeplinkRpcReceiver.registerHandler, deeplink_rpc.DeeplinkRpcClient.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:deeplink_rpc/deeplink_rpc.dart that imports:
  • package:deeplink_rpc/src/receiver.dart that imports:
  • package:deeplink_rpc/src/handler.dart that imports:
  • package:deeplink_rpc/src/data/response.dart that imports:
  • package:deeplink_rpc/src/codec.dart that imports:
  • package:archive/archive_io.dart that imports:
  • package:archive/src/io/zip_file_encoder.dart that imports:
  • package:archive/src/io/output_file_stream.dart that imports:
  • package:archive/src/io/file_handle.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/data/failure.freezed.dart:141:17

    ╷
141 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/data/failure.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/data/request.freezed.dart:172:17

    ╷
172 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/data/request.freezed.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.2 3.6.0 3.6.0
flutter flutter 0.0.0 0.0.0
freezed_annotation ^2.4.1 2.4.1 2.4.1
json_annotation ^4.8.1 4.9.0 4.9.0
url_launcher ^6.1.14 6.2.6 6.2.6
uuid ^4.1.0 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

1
likes
110
pub points
62%
popularity

Publisher

verified publisherarchethic.net

A RPC-via-deeplink communication library coded in Dart. This is dedicated to Flutter mobile applications (iOS / Android).

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

AGPL-3.0 (LICENSE)

Dependencies

archive, flutter, freezed_annotation, json_annotation, url_launcher, uuid

More

Packages that depend on deeplink_rpc