deepl_dart 0.3.0 copy "deepl_dart: ^0.3.0" to clipboard
deepl_dart: ^0.3.0 copied to clipboard

Dart library for the DeepL language translation API.

20
likes
120/ 140
pub points
77%
popularity

We analyzed this package 4 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 79 API elements (68.4 %) have documentation comments.

Some symbols that are missing documentation: deepl_dart, deepl_dart.DocumentHandle.DocumentHandle.fromJson, deepl_dart.DocumentStatus.DocumentStatus.fromJson, deepl_dart.DocumentStatusCode, deepl_dart.DocumentStatusCode.DocumentStatusCode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:deepl_dart/deepl_dart.dart that imports:
  • package:deepl_dart/src/translator.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
http ^0.13.4 0.13.6 1.2.1
json_annotation ^4.4.0 4.8.1 4.8.1
json_serializable ^6.1.5 6.7.1 6.7.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.4 2.3.4
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
source_gen - 1.5.0 1.5.0
source_helper - 1.3.4 1.3.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.