database_viewer 2.0.0 copy "database_viewer: ^2.0.0" to clipboard
database_viewer: ^2.0.0 copied to clipboard

A database viewer plugin.

1
likes
95/ 140
pub points
2%
popularity

We analyzed this package 3 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
5 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: database_viewer, database_viewer.DatabaseViewer, database_viewer.DatabaseViewer.DATABASE_VIEWER_CHANNEL, database_viewer.DatabaseViewer.DatabaseViewer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:database_viewer/database_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:database_viewer/database_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:database_viewer/database_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:database_viewer/database_viewer.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/database_viewer.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
floor ^1.4.2 1.4.2 1.4.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
floor_annotation - 1.4.2 1.4.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite - 2.3.2 2.3.2
sqflite_common - 2.5.3 2.5.3
sqflite_common_ffi - 2.3.2+1 2.3.2+1
sqlite3 - 2.4.0 2.4.0
sqlparser - 0.27.0 0.34.1
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

1
likes
95
pub points
2%
popularity

Publisher

unverified uploader

A database viewer plugin.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

floor, flutter

More

Packages that depend on database_viewer