dash_kit_loadable 2.1.2
dash_kit_loadable: ^2.1.2 copied to clipboard

Widgets for displaying different request states without additional code.

0
likes
90 / 110
pub points
56 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 80 API elements (11.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dash_kit_core^2.1.22.1.22.1.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async_redux-7.0.29.0.3
built_collection-4.3.25.0.0
characters-1.1.01.1.0
collection-1.15.01.15.0
fast_immutable_collections-1.1.03.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
weak_map-1.3.12.0.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
90
pub points
56%
popularity

Widgets for displaying different request states without additional code.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

flutter.dash.kit@gmail.com

License

MIT (LICENSE)

Dependencies

dash_kit_core, flutter

More

Packages that depend on dash_kit_loadable