dartssh 1.0.3+3

Library providing a pure Dart SSH implementation with tunneling.

7
likes
70 / 110
pub points
50 %
popularity

We analyzed this package on Sep 28, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/dartssh.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 459 out of 1462 API elements (31.4 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The value of the local variable 'procType' isn't used.

lib/pem.dart:51:35

   ╷
51 │   String headersEndText = '\n\n', procType;
   │                                   ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/pem.dart

INFO: Unused import: 'package:dartssh/socket_html.dart'.

lib/socket.dart:7:8

  ╷
7 │ import 'package:dartssh/socket_html.dart'
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/socket.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.5.110.5.150.8.1
convert^2.1.12.1.12.1.1
http^0.12.0+20.12.20.12.2
meta^1.1.61.2.31.2.3
pedantic^1.8.01.9.21.9.2
pointycastle^1.0.11.0.21.0.2
tweetnacl^0.3.20.3.20.3.2
validators^2.0.0+12.0.0+12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
fixnum-0.10.110.10.11
http_parser-3.1.43.1.4
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.11` on asn1lib does not support the latest published version `0.8.1`

pubspec.yaml:11:12

   ╷
11 │   asn1lib: ^0.5.11
   │            ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

7
likes
70
pub points
50%
popularity

Library providing a pure Dart SSH implementation with tunneling.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

greenappers@gmail.com

License

MIT (LICENSE)

Dependencies

asn1lib, convert, http, meta, pedantic, pointycastle, tweetnacl, validators

More

Packages that depend on dartssh