dartbase_admin 0.1.4
dartbase_admin: ^0.1.4 copied to clipboard

Dart native
Flutter Android iOS

A dart-native implementation of the Firebase Admin SDK to enable administrive tasks to your firebase project.

3
likes
70 / 110
pub points
56 %
popularity

We analyzed this package on Jan 23, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 391 out of 2372 API elements (16.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartbase_admin/dartbase_admin.dart that imports:
  • package:dartbase_admin/firestore/models.dart that imports:
  • package:dartbase_admin/firestore/firestore_gateway.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 86 issues. Showing the first 2:

INFO: 'copyWith' is deprecated and shouldn't be used. Using this can add significant size overhead to your binary. Use [GeneratedMessageGenericExtensions.rebuild] instead. Will be removed in next major version.

lib/generated/google/firestore/v1/common.pb.dart:31:13

   ╷
31 │       super.copyWith((message) => updates(message as DocumentMask));
   │             ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/google/firestore/v1/common.pb.dart

INFO: 'copyWith' is deprecated and shouldn't be used. Using this can add significant size overhead to your binary. Use [GeneratedMessageGenericExtensions.rebuild] instead. Will be removed in next major version.

lib/generated/google/firestore/v1/common.pb.dart:74:13

   ╷
74 │       super.copyWith((message) => updates(message as Precondition));
   │             ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/google/firestore/v1/common.pb.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.6.40.6.50.8.1
clock^1.0.11.0.11.0.1
corsac_jwt^0.2.20.2.20.4.0
crypto_keys^0.1.20.1.30.1.3
fixnum^0.10.110.10.110.10.11
gcloud^0.7.0+10.7.30.7.3
googleapis_auth^0.2.110.2.120.2.12
grpc^2.1.32.8.02.8.0
http^0.12.20.12.20.12.2
jose^0.1.2+10.1.2+10.2.1+1
json_annotation^3.0.13.1.13.1.1
meta^1.1.81.2.41.2.4
openid_client^0.2.50.2.50.3.1
pointycastle^1.0.21.0.22.0.1
protobuf^1.0.11.1.01.1.0
x509^0.1.0+10.1.30.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.2.00.2.0
args-1.6.01.6.0
async-2.4.22.4.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
googleapis-0.56.10.56.1
http2-1.0.11.0.1
http_parser-3.1.43.1.4
logging-0.11.40.11.4
matcher-0.12.90.12.9
path-1.7.01.7.0
quiver-2.1.52.1.5
rsa_pkcs-1.1.31.1.4
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.6.4` on asn1lib does not support the latest published version `0.8.1`

pubspec.yaml:16:12

   ╷
16 │   asn1lib: ^0.6.4
   │            ^^^^^^
   ╵
The constraint `^0.2.2` on corsac_jwt does not support the latest published version `0.4.0`

pubspec.yaml:26:15

   ╷
26 │   corsac_jwt: ^0.2.2
   │               ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
56%
popularity

A dart-native implementation of the Firebase Admin SDK to enable administrive tasks to your firebase project.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

saadodi44@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

asn1lib, clock, corsac_jwt, crypto_keys, fixnum, gcloud, googleapis_auth, grpc, http, jose, json_annotation, meta, openid_client, pointycastle, protobuf, x509

More

Packages that depend on dartbase_admin