dart_periphery 0.8.0-beta
dart_periphery: ^0.8.0-beta copied to clipboard

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

8
likes
80 / 120
pub points
42 %
popularity

We analyzed this package on Jun 22, 2021, and awarded it 80 pub points (of a possible 120):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/example.dart
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_periphery/dart_periphery.dart that imports:
  • package:dart_periphery/src/bme280.dart that imports:
  • package:dart_periphery/src/util.dart that imports:
  • package:dart_periphery/src/spi.dart that imports:
  • package:dart_periphery/src/signature.dart that imports:
  • package:dart_periphery/src/library.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.1.2
path^1.7.01.8.01.8.0
pedantic^1.9.21.11.11.11.1
process^3.0.133.0.134.2.1
system_info^0.1.30.1.31.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
file-5.2.16.1.2
file_utils-0.1.41.0.0
globbing-0.3.11.0.0
intl-0.16.10.17.0
meta-1.4.01.4.0
platform-3.0.03.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^3.0.13` on process does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions process to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

8
likes
80
pub points
42%
popularity

Publisher

Unknown

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

Repository (GitHub)
View/report issues

License

BSD (LICENSE)

Dependencies

ffi, path, pedantic, process, system_info

More

Packages that depend on dart_periphery