dart_periphery 0.8.22-beta
dart_periphery: ^0.8.22-beta copied to clipboard

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

4
likes
110 / 130
pub points
50 %
popularity

We analyzed this package on Apr 17, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 467 out of 885 API elements (52.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_periphery/dart_periphery.dart that imports:
  • package:dart_periphery/src/hardware/bme680.dart that imports:
  • package:dart_periphery/src/i2c.dart that imports:
  • package:dart_periphery/src/signature.dart that imports:
  • package:dart_periphery/src/library.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/errno.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
ffi^1.0.01.0.01.0.0
path^1.8.01.8.01.8.0
pedantic^1.11.01.11.01.11.0
process^4.2.14.2.14.2.1
system_info^1.0.01.0.01.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
file-6.1.06.1.0
file_utils-1.0.01.0.0
globbing-1.0.01.0.0
meta-1.3.01.3.0
platform-3.0.03.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

4
likes
110
pub points
50%
popularity

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

wechselkroete@gmail.com

License

BSD (LICENSE)

Dependencies

collection, ffi, path, pedantic, process, system_info

More

Packages that depend on dart_periphery