dart_periphery 0.8.23-beta
dart_periphery: ^0.8.23-beta copied to clipboard

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dart_periphery

With Flutter:

 $ flutter pub pub add dart_periphery

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  dart_periphery: ^0.8.23-beta

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dart_periphery/dart_periphery.dart';
4
likes
110
pub points
50%
popularity

dart_periphery is a Dart port of the native c-periphery library for Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO and Serial peripheral I/O).

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

wechselkroete@gmail.com

License

BSD (LICENSE)

Dependencies

collection, ffi, path, pedantic, process, stack_trace, system_info

More

Packages that depend on dart_periphery