dart_cmder 0.0.5-prerelease copy "dart_cmder: ^0.0.5-prerelease" to clipboard
dart_cmder: ^0.0.5-prerelease copied to clipboard

This Dart package offers a streamlined and intuitive interface for building powerful Command Line Interface (CLI) applications.

6
likes
160/ 160
pub points
5%
popularity

We analyzed this package 14 hours ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/nikosportolos/dart_cmder/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

82 out of 141 API elements (58.2 %) have documentation comments.

Some symbols that are missing documentation: dart_cmder, dart_cmder.ArgParserX, dart_cmder.ArgParserX.addArgument, dart_cmder.ArgParserX.addArguments, dart_cmder.BaseArgument.abbr.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/interface/interface.dart that imports:
  • package:dart_cmder/src/interface/arguments/arguments.dart that imports:
  • package:dart_cmder/src/interface/arguments/multi_enum.dart that imports:
  • package:dart_cmder/src/tools/enums.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/interface/interface.dart that imports:
  • package:dart_cmder/src/interface/arguments/arguments.dart that imports:
  • package:dart_cmder/src/interface/arguments/multi_enum.dart that imports:
  • package:dart_cmder/src/tools/enums.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/tools/tools.dart that imports:
  • package:dart_cmder/src/tools/finder.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansix ^0.3.1 0.3.3 0.3.3
args ^2.4.2 2.5.0 2.5.0
meta ^1.11.0 1.15.0 1.15.0
path ^1.8.3 1.9.0 1.9.0
trace ^0.0.6-prerelease 0.0.6-prerelease 0.0.6-prerelease
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 70.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.6.0
analyzer_plugin - 0.11.3 0.11.3
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
data_class_plugin - 1.4.1 1.4.1
date_time_format - 2.0.1 2.0.1
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
macros - 0.1.0-main.0 0.1.2-main.3
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
rxdart - 0.27.7 0.28.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
tachyon - 0.3.0 0.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

6
likes
160
pub points
5%
popularity
screenshot

Publisher

verified publishernikosportolos.com

This Dart package offers a streamlined and intuitive interface for building powerful Command Line Interface (CLI) applications.

Repository (GitHub)
View/report issues
Contributing

Topics

#cli #console #command #interface #terminal

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

ansix, args, meta, path, trace

More

Packages that depend on dart_cmder