dart_board_firebase_database 1.0.20 copy "dart_board_firebase_database: ^1.0.20" to clipboard
dart_board_firebase_database: ^1.0.20 copied to clipboard

Firebase Database Binding's

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 26 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: dart_board_firebase_database, dart_board_firebase_database.CollectionView.builder, dart_board_firebase_database.CollectionView.ref, dart_board_firebase_database.DartBoardFirebaseDatabaseFeature, dart_board_firebase_database.DartBoardFirebaseDatabaseFeature.DartBoardFirebaseDatabaseFeature.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:dart_board_firebase_database/dart_board_firebase_database.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Package not compatible with platform Web

Because:

  • package:dart_board_firebase_database/dart_board_firebase_database.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/dart_board_firebase_database.dart:72:36

   ╷
72 │             WidgetsBinding.instance?.addPostFrameCallback((timeStamp) {
   │                                    ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/dart_board_firebase_database.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cloud_firestore ^4.4.4 4.16.1 4.16.1
dart_board_core ^0.9.16+7 0.9.16+7 0.9.16+7
dart_board_firebase_core ^1.4.7 1.4.7 1.4.7
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.29 1.3.29
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 6.1.13 6.1.13
cloud_firestore_web - 3.11.1 3.11.1
collection - 1.18.0 1.18.0
dart_board_widgets - 1.10.0 1.10.0
fake_async - 1.3.1 1.3.1
firebase_core - 2.29.0 2.29.0
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.15.0 2.15.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
intl - 0.17.0 0.19.0
leak_tracker - 10.0.0 10.0.5
leak_tracker_flutter_testing - 2.0.1 3.0.5
leak_tracker_testing - 2.0.1 3.0.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.2.0
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.