dart_board_chat 1.12.0 copy "dart_board_chat: ^1.12.0" to clipboard
dart_board_chat: ^1.12.0 copied to clipboard

Realtime Chat based on Firebase Firestore.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 61 API elements (27.9 %) have documentation comments.

Some symbols that are missing documentation: chat_config, chat_config.ChatConfig.buildMessageRow, chat_config.ChatConfig.buildNewMessageRow, dart_board_chat, dart_board_chat.ChannelWidget.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:dart_board_chat/dart_board_chat.dart that imports:
  • package:dart_board_chat/chat_config.dart that imports:
  • package:dart_board_chat/message_row.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Package not compatible with platform Web

Because:

  • package:dart_board_chat/dart_board_chat.dart that imports:
  • package:dart_board_chat/chat_config.dart that imports:
  • package:dart_board_chat/message_row.dart that imports:
  • package:dart_board_locator/dart_board_locator.dart that imports:
  • package:dart_board_core/dart_board_core.dart that imports:
  • package:dart_board_core/impl/dart_board_core.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: Unused import: 'package:cloud_firestore/cloud_firestore.dart'.

lib/message_row.dart:1:8

  ╷
1 │ import 'package:cloud_firestore/cloud_firestore.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/message_row.dart

INFO: The import of 'package:flutter/src/widgets/framework.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/chat_config.dart:3:8

  ╷
3 │ import 'package:flutter/src/widgets/framework.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/chat_config.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cloud_firestore ^4.4.4 4.15.6 4.15.6
dart_board_authentication ^1.2.7 1.2.7 1.2.7
dart_board_core ^0.9.16+7 0.9.16+7 0.9.16+7
dart_board_firebase_database ^1.0.20 1.0.20 1.0.20
dart_board_locator ^0.9.12 0.9.12 0.9.12
flutter flutter 0.0.0 0.0.0
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.23 1.3.23
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 6.1.7 6.1.7
cloud_firestore_web - 3.10.6 3.10.6
collection - 1.18.0 1.18.0
dart_board_firebase_core - 1.4.7 1.4.7
dart_board_widgets - 1.10.0 1.10.0
fake_async - 1.3.1 1.3.1
firebase_core - 2.25.5 2.25.5
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.11.5 2.11.5
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.1.0
web - 0.4.2 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.