daco 0.2.6 copy "daco: ^0.2.6" to clipboard
daco: ^0.2.6 copied to clipboard

A tool for maintaining Dart comments. Supports formatting of comments, including embedded Dart code.

7
likes
120/ 140
pub points
50%
popularity

We analyzed this package 37 hours ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/blaugold/daco/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Implicit tear-off of the 'call' method.

lib/src/commands/analyze.dart:117:26

    ╷
117 │         errorCodeStyle = AnsiStyles.red;
    │                          ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/commands/analyze.dart

INFO: Implicit tear-off of the 'call' method.

lib/src/commands/analyze.dart:120:26

    ╷
120 │         errorCodeStyle = AnsiStyles.yellow;
    │                          ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/commands/analyze.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
_fe_analyzer_shared ^60.0.0 60.0.0 67.0.0
analyzer ^5.12.0 5.12.0 6.4.1
analyzer_plugin ^0.11.2 0.11.2 0.11.3
ansi_styles ^0.3.2+1 0.3.2+1 0.3.2+1
args ^2.3.1 2.4.2 2.4.2
cli_launcher ^0.3.0 0.3.1 0.3.1
cli_util ^0.3.5 0.3.5 0.4.1
collection ^1.16.0 1.18.0 1.18.0
dart_style ^2.3.1 2.3.2 2.3.6
http ^0.13.4 0.13.6 1.2.1
path ^1.8.0 1.9.0 1.9.0
pubspec_parse ^1.2.0 1.2.3 1.2.3
solvent ^0.1.1 0.1.1 0.1.1
synchronized ^3.0.0+2 3.1.0+1 3.1.0+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
meta - 1.12.0 1.12.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^60.0.0` on _fe_analyzer_shared does not support the stable version `61.0.0`.

Try running dart pub upgrade --major-versions _fe_analyzer_shared to update the constraint.

The constraint `^5.12.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.