custom_lint 0.6.4 copy "custom_lint: ^0.6.4" to clipboard
custom_lint: ^0.6.4 copied to clipboard

Lint rules are a powerful way to improve the maintainability of a project. Custom Lint allows package authors and developers to easily write custom lint rules.

181
likes
150/ 160
pub points
100%
popularity

We analyzed this package 36 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 3 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: basic_runner, custom_lint.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:custom_lint/custom_lint.dart that imports:
  • package:custom_lint/src/workspace.dart that imports:
  • package:package_config/package_config.dart that imports:
  • package:package_config/src/package_config_io.dart that imports:
  • package:package_config/src/util_io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/workspace.dart:463:34

    ╷
463 │       contextRootsWithCustomLint.whereNotNull().toList(),
    │                                  ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/workspace.dart

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/workspace.dart:560:12

    ╷
560 │           .whereNotNull()
    │            ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/workspace.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.12.0 <7.0.0 6.5.0 6.7.0
analyzer_plugin ^0.11.0 0.11.3 0.11.3
args ^2.3.1 2.5.0 2.5.0
async ^2.9.0 2.11.0 2.11.0
ci ^0.1.0 0.1.0 0.1.0
cli_util ^0.4.0 0.4.1 0.4.1
collection ^1.16.0 1.19.0 1.19.0
custom_lint_core 0.6.3 0.6.3 0.6.3
freezed_annotation ^2.2.0 2.4.3 2.4.3
json_annotation ^4.7.0 4.9.0 4.9.0
meta ^1.7.0 1.15.0 1.15.0
package_config ^2.0.2 2.1.0 2.1.0
path ^1.8.0 1.9.0 1.9.0
pub_semver ^2.1.1 2.1.4 2.1.4
pubspec_parse ^1.2.0 1.3.0 1.3.0
rxdart ^0.27.7 0.27.7 0.28.0
uuid >=3.0.6 <5.0.0 4.4.2 4.4.2
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 72.0.0
_macros - 0.1.0 0.1.0
boolean_selector - 2.1.1 2.1.1
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
macros - 0.1.0-main.0 0.1.2-main.4
matcher - 0.12.16+1 0.12.16+1
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 28 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

181
likes
150
pub points
100%
popularity

Publisher

verified publisherinvertase.io

Lint rules are a powerful way to improve the maintainability of a project. Custom Lint allows package authors and developers to easily write custom lint rules.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

analyzer, analyzer_plugin, args, async, ci, cli_util, collection, custom_lint_core, freezed_annotation, json_annotation, meta, package_config, path, pub_semver, pubspec_parse, rxdart, uuid, yaml

More

Packages that depend on custom_lint