cruzawl_ui 1.0.0+0
cruzawl_ui: ^1.0.0+0 copied to clipboard

Flutter package for the CRUZ cryptocurrency and the cruzbit.1 network.

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +81 ms] executing: uname -m
[  +38 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +7 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +8 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[        ] executing: [/tool/stable/flutter/] git tag --points-at 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[  +15 ms] Exit code 0 from: git tag --points-at 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[        ] 2.5.2
[  +11 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +6 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +65 ms] Unable to locate an Android SDK.
[   +5 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +6 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +62 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +12 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/pub upgrade --verbose
MSG : Resolving dependencies...
[+1463 ms] "flutter pub" took 1,561ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1

stderr: FINE: Pub 2.14.3
SLVR: fact: cruzawl_ui is 1.0.0+0
SLVR: derived: cruzawl_ui
SLVR: fact: cruzawl_ui depends on barcode_scan ^1.0.0
SLVR: fact: cruzawl_ui depends on bip39 ^1.0.3
SLVR: fact: cruzawl_ui depends on charts_flutter ^0.8.1
SLVR: fact: cruzawl_ui depends on collection ^1.14.11
SLVR: fact: cruzawl_ui depends on cruzawl ^1.0.9
SLVR: fact: cruzawl_ui depends on flutter any from sdk
SLVR: fact: cruzawl_ui depends on flutter_localizations any from sdk
SLVR: fact: cruzawl_ui depends on gradient_app_bar ^0.0.1
SLVR: fact: cruzawl_ui depends on intl ^0.15.2
SLVR: fact: cruzawl_ui depends on json_annotation ^3.0.0
SLVR: fact: cruzawl_ui depends on pedantic ^1.8.0
SLVR: fact: cruzawl_ui depends on qr_flutter ^3.0.1
SLVR: fact: cruzawl_ui depends on scoped_model ^1.0.1
SLVR: fact: cruzawl_ui depends on sembast ^2.0.1
SLVR: fact: cruzawl_ui depends on syntax_highlighter ^0.1.0
SLVR: fact: cruzawl_ui depends on tuple ^1.0.2
SLVR: fact: cruzawl_ui depends on tweetnacl ^0.3.2
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>



Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/explorer/chart/block.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/l10n/messages_all.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because cruzawl_ui depends on flutter_localizations any from sdk which depends on intl 0.17.0, intl 0.17.0 is required.
So, because cruzawl_ui depends on intl ^0.15.2, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.