cruzawl_ui 1.0.0+0

  • Readme
  • Changelog
  • Installing
  • 12

cruzawl-ui Build Status Coverage Status #

Flutter package for CRUZ cryptocurrency wallet cruzall and block explorer cruzweb.

Project Map #

License #

cruzawl-ui is released under the terms of the MIT license. See LICENSE for more information or see https://opensource.org/licenses/MIT.

Discussion #

  • Discord server for general chat as well as updates, including development status.

Donations #

Right on! RWEgB+NQs/T83EkmIFNVJG+xK64Hm90GmQgrdR2V7BI=

1.0.0+0 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cruzawl_ui: ^1.0.0+0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cruzawl_ui/explorer/address.dart';
import 'package:cruzawl_ui/explorer/block.dart';
import 'package:cruzawl_ui/explorer/chart/block.dart';
import 'package:cruzawl_ui/explorer/console.dart';
import 'package:cruzawl_ui/explorer/network.dart';
import 'package:cruzawl_ui/explorer/settings.dart';
import 'package:cruzawl_ui/explorer/transaction.dart';
import 'package:cruzawl_ui/l10n/messages_all.dart';
import 'package:cruzawl_ui/l10n/messages_ar.dart';
import 'package:cruzawl_ui/l10n/messages_cs.dart';
import 'package:cruzawl_ui/l10n/messages_de.dart';
import 'package:cruzawl_ui/l10n/messages_en.dart';
import 'package:cruzawl_ui/l10n/messages_es.dart';
import 'package:cruzawl_ui/l10n/messages_he.dart';
import 'package:cruzawl_ui/l10n/messages_id.dart';
import 'package:cruzawl_ui/l10n/messages_ja.dart';
import 'package:cruzawl_ui/l10n/messages_ko.dart';
import 'package:cruzawl_ui/l10n/messages_ms.dart';
import 'package:cruzawl_ui/l10n/messages_ru.dart';
import 'package:cruzawl_ui/l10n/messages_zh.dart';
import 'package:cruzawl_ui/localization.dart';
import 'package:cruzawl_ui/model.dart';
import 'package:cruzawl_ui/routes.dart';
import 'package:cruzawl_ui/ui.dart';
import 'package:cruzawl_ui/ui_html.dart';
import 'package:cruzawl_ui/ui_io.dart';
import 'package:cruzawl_ui/wallet/add.dart';
import 'package:cruzawl_ui/wallet/address.dart';
import 'package:cruzawl_ui/wallet/app.dart';
import 'package:cruzawl_ui/wallet/balance.dart';
import 'package:cruzawl_ui/wallet/contacts.dart';
import 'package:cruzawl_ui/wallet/receive.dart';
import 'package:cruzawl_ui/wallet/send.dart';
import 'package:cruzawl_ui/wallet/settings.dart';
import 'package:cruzawl_ui/wallet/wallet.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
12
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because cruzawl_ui depends on flutter_localizations any from sdk which depends on intl 0.16.0, intl 0.16.0 is required.
 So, because cruzawl_ui depends on intl ^0.15.2, version solving failed.

Health suggestions

Format lib/explorer/chart/block.dart.

Run flutter format to format lib/explorer/chart/block.dart.

Format lib/l10n/messages_all.dart.

Run flutter format to format lib/l10n/messages_all.dart.

Format lib/l10n/messages_ar.dart.

Run flutter format to format lib/l10n/messages_ar.dart.

Fix additional 11 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/l10n/messages_cs.dart (Run flutter format to format lib/l10n/messages_cs.dart.)
  • lib/l10n/messages_de.dart (Run flutter format to format lib/l10n/messages_de.dart.)
  • lib/l10n/messages_en.dart (Run flutter format to format lib/l10n/messages_en.dart.)
  • lib/l10n/messages_es.dart (Run flutter format to format lib/l10n/messages_es.dart.)
  • lib/l10n/messages_he.dart (Run flutter format to format lib/l10n/messages_he.dart.)
  • lib/l10n/messages_id.dart (Run flutter format to format lib/l10n/messages_id.dart.)
  • lib/l10n/messages_ja.dart (Run flutter format to format lib/l10n/messages_ja.dart.)
  • lib/l10n/messages_ko.dart (Run flutter format to format lib/l10n/messages_ko.dart.)
  • lib/l10n/messages_ms.dart (Run flutter format to format lib/l10n/messages_ms.dart.)
  • lib/l10n/messages_ru.dart (Run flutter format to format lib/l10n/messages_ru.dart.)
  • lib/l10n/messages_zh.dart (Run flutter format to format lib/l10n/messages_zh.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cruzawl_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0