cronet_http 1.1.1 copy "cronet_http: ^1.1.1" to clipboard
cronet_http: ^1.1.1 copied to clipboard

PlatformAndroid

An Android Flutter plugin that provides access to the Cronet HTTP client.

33
likes
140/ 140
pub points
87%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 19 API elements (94.7 %) have documentation comments.

Some symbols that are missing documentation: cronet_http.CronetEngine.close.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:cronet_http/cronet_http.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:cronet_http/cronet_http.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:cronet_http/cronet_http.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:cronet_http/cronet_http.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:cronet_http/cronet_http.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^1.2.0 1.2.1 1.2.1
jni ^0.7.2 0.7.2 0.7.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

33
likes
140
pub points
87%
popularity

Publisher

verified publisherdart.dev

An Android Flutter plugin that provides access to the Cronet HTTP client.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, http, jni

More

Packages that depend on cronet_http